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What is EMCO Network Inventory

EMCO  Network  Inventory  is  an  advanced,  easy  to  use  tool  that  helps  systems  administrators  get  up-to-date
information about the hardware and software available on computers in the office Local Area Network (LAN) or
Wide Area Network (WAN). Using EMCO Network Inventory, you can quickly scan all the  computers  in your
network and generate a report about  the  hardware  and  software  installed  on the  computers.  You can also  keep
track of application licenses on all the computers in your network.

EMCO Network Inventory 5 performs fast and comprehensive  PC  hardware  inventory and  software  audits  with
very little load on the network, it is low priced and very easy to use.

EMCO Network Inventory can help you answer such questions as:

How many computers in your network are running MS Vista? 

Which computers are still running WinXP and have less than 1GB RAM?

On which computers is Photoshop CS3 installed and how much did you spend for it?

Do you need more software licenses or do you have enough?

How much extra hardware would you need if you were to change the operating system?

Are there any unwanted files like .mp3 or .avi files and who has them?

Is there any adware or spyware on any of the machines in the network?

EMCO Network Inventory is one of the most popular inventory tools in the market. It is being used  by industrial
leaders, small businesses, governments, nonprofit organizations and educational institutions.

Main Features of EMCO Network Inventory

Using EMCO Network Inventory, you can -

Collect  information  about  the  hardware  on  computers  in  your  network,  such  as  the  processor,  memory,
motherboard, video card, monitor, etc. 

Collect information about the Operating System and Service Packs installed on computers in your network.

Automatically add new machines into the database using the Auto-Fetch schedule.

Scan computers by using a specific domain name or a range of IP addresses.

Get a list of installed applications and hotfixes, running processes and services, etc.

Perform custom scans using user-defined specifications.

Store all scanned information in a database.

Search the registry of any machine on the network for a specific key or value.

Keep  track  of  all  purchased  software  licenses,  and  calculate  the  number  of  licenses  required  for  installed
applications, taking versions into account.

Compare the number of required licenses against available licenses.

Automatically calculate license costs.

Identify  changes  that  may  have  occurred  in  licenses  between  networks  or  at  different  times  on  the  same
network.

Generate print-ready reports in one of the following formats: PDF, HTML, RTF, JPEG, or plain text.

Customize the information to be included in the reports.

Create pie charts, bar charts or line charts from the collected data.

Export data to Microsoft Excel.
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Installing on the Local Machine
EMCO Network Inventory needs to be installed on just one machine in your network.

When  you  install  EMCO  Network  Inventory,  two  stub  files  are  also  installed.  Use  these  stub  files  to  collect
information from Windows 9.x and NT machines.

See "Installing on Remote Computers" for more details about using the stub files.

To install EMCO Network Inventory on the local machine:

1. Double-click on the Network Inventory setup  exe  file  that  you have  downloaded  from the  EMCO  Network
Inventory Downloads page.

The setup file for EMCO  Network  Inventory Enterprise  Edition is  networkinventoryentsetup.exe,  and  for
the  Professional  Edition  it  is  networkinventoryprosetup.exe,  and  for  The  Starter  Edition  is
networkinventorystartersetup.exe

If you have downloaded the archived setup file, you will have to first extract the above-named setup exe file
from the zip file that you have downloaded.

2. On the first screen of the setup program, click Next.

The License Agreement will be displayed.

The EMCO Network Inventory License Agreement

3. Click on I accept the agreement and then click Next.
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Select Destination Location

4. Click Next.

Select Start Menu Folder

5. Click Next.
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Select Additional Tasks

6. Click Next.

Setup Summary

7. Click Install.
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The EMCO Network Inventory program will be installed to the desired location. Once the program is installed
the following screen is displayed.

Completing the EMCO Network Inventory Setup

8. Click  Finish to  complete  the  installation.  If you have  selected  the  Launch EMCO  Network  Inventory check
box, the EMCO Network Inventory is launched.

Installing on Remote Computers

It  is  not  necessary  to  install  EMCO  Network  Inventory  on  every  machine  in  your  network.  Instead,  EMCO
provides special programs called stub analyzers to collect information from Win9x and NT machines. To use these
stub analyzers, you need to copy the relevant stub analyzer files to the Win9x and NT machines and execute them.
When you execute the stub analyzer on a computer, it collects the information about that computer and stores it in a
file called <MACHINE NAME>.mdax5x (where <MACHINE NAME> is the name of the computer on which the
stub  analyzer  is  executed).  You  can  then  import  this  information  into  EMCO  Network  Inventory  for  charting,
reporting and printing. 

You should run these stub analyzers individually on each machine to collect the information of that machine,
because  if there  is  concurrent  access  for  the  data  folder  by  more  then  one  machine,  it  can  corrupt  the
information and the data will not be consistent.

To use a stub analyzer:

1. Create a temporary folder on the computer that you want to scan.

2. From the C:\Program Files\EMCO\Network Inventory Enterprise\Stubs folder, copy the relevant stub analyzer
file—MInfo9x.exe  for  a  Win9x machine,  or  MInfoNT.exe  for  a  WinNT  machine—and  the  Options.ini  and
Default.csc5x files and paste them into this temporary folder.

3. If necessary, configure the Options.ini file to match your requirements.

4. Run the stub analyzer file—MInfo9x.exe or MInfoNT.exe. The stub analyzer will collect the information about
the computer and store it in the <MACHINE NAME>.mdax5x file.

5. On  the  local  machine,  start  EMCO  Network  Inventory,  and  import  the  scan  data  from the  <MACHINE
NAME>.mdax5x file.
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The following table describes the commands you can use in the Options.ini file:

Command Description

 Use Directory= Set this to 1 if you want the scan results should be stored in a
folder. Otherwise, set this to 0 (zero).

 Use Directory=1

 Directory= Specify  the  name  of  the  folder  in  which  to  store  the  scan
results. This is used only if you have set 'Use Directory' to 1.

 Directory=c:\Temp

 RunOnce= Set this to 1 if you want to  run the  stub  analyzer  only once.
Otherwise, set this to 0 (zero). RunOnce will only execute the
stub if no data exists for the machine.

 RunOnce=0

 AllData= If you set AllData to 0 , specify what information you want to
scan by setting the corresponding command to 1.

 AllData=1

ShareAccess, NetworkPrinters, HotFixes, and UserAccounts are not available in Win9x.

Command Default Value

 BasicInfo=  BasicInfo=0

 OSDescription=  OSDescription=0

 WMIInfo=  WMIInfo=0

 UseWMIforPhysicalMemory=  UseWMIforPhysicalMemory=0

 DigitalProductID=  DigitalProductID=0

 OfficeDigitalProductID=  OfficeDigitalProductID=0

 InstalledApps=  InstalledApps=0

 CustomScans=  CustomScans=0

 Shares=  Shares=0

 ShareAccess=  ShareAccess=0

 Printers=  Printers=0

 NetworkPrinters=  NetworkPrinters=0

 MappedDrives=  MappedDrives=0

 DiskInfo=  DiskInfo=0

 CdromDrives=  CdromDrives=1

 Processes=  Processes=0

 StartupCommands=  StartupCommands=0

 ProgramFolders=  ProgramFolders=0

 Processors=  Processors=0

 NetworkCards=  NetworkCards=0

 EnvironmentalVars=  EnvironmentalVars=0

 UserEnvVars=  UserEnvVars=0

 Services=  Services=0

 MemoryBanks=  MemoryBanks=0

 DataSourcesODBC=  DataSourcesODBC=0

 UserDataSourcesODBC=  UserDataSourcesODBC=0

 HotFixes=  HotFixes=0
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 ScheduledTasks=  ScheduledTasks=0

 Fonts=  Fonts=0

There is no need to use the stub analyzers if your computers are operating under Windows NT, Windows
2000, Windows XP Pro or Windows Vista SP1, and you have the required ports open. EMCO Network
Inventory can directly scan computers that use these operating systems.

Getting Started with EMCO Network Inventory

In this section, we shall see how to -

Start EMCO Network Inventory. 

Scan the network for data.

View reports.

Export the collected data to Excel.

Starting EMCO Network Inventory

To start EMCO Network Inventory:

1. Click Start > All Programs > EMCO > Network Inventory Enterprise > Network Inventory Enterprise.

If you have  installed  the  Professional version of Network  Inventory,  you  will  have  to  select  Start  >  All
Programs >  EMCO  >  Network  Inventory Professional >  Network  Inventory  Professional  in  the  above
menu.

If you have installed the Starter version of Network Inventory, you will have to select Start > All Programs
> EMCO > Network Inventory Starter > Network Inventory Starter in the above menu.

OR

1. Double-click on the EMCO Network Inventory icon on your desktop.

If this is the first time you are running EMCO Network Inventory, the following message will be displayed:

Note down the folder name that is displayed in the message. EMCO Network Inventory will not be able to
function properly if any other program tries to access the DATA folder. Therefore, you should exclude the
DATA folder from your anti-virus scans. (Refer to your anti-virus program's user guide for more information
on excluding folders from scans.)

After noting down the folder name, click OK to close the dialog box.
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2. If you have  not  yet  activated  your  copy of EMCO  Network  Inventory,  the  Trial dialog is  displayed  on  the
screen.

Closing EMCO Network Inventory

To close EMCO Network Inventory:

Click File > Exit. 

OR

Click Close button at the top right hand corner of the EMCO Network Inventory program window. 
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The Main Screen

The Main EMCO Network Inventory Screen

Importing Data from the Stub Analyzers into EMCO Network Inventory

If you do want to get the scan information from the Machines running on Windows 9X you should install, configure
and execute the stub analyzers on them. Once the stub analyzers have been run, you can import the collected data
into EMCO Network Inventory's database.

Refer to the next section, 'Installing on Remote Computers' for more information about the stub analyzers.

To import the stub analyzer data:

As you click on items in the left panel, the details of the selected item appear in this panel.

Select  these  tabs  to  (a)  manage  the  information  collected  from the  machines  on  your  network,  (b)  change  the
EMCO Network Inventory settings, or (c) provide alternate credentials.

Select items from this list to view details and perform other operations on the collected information.

1. In the main EMCO Network Inventory screen, right-click on Networking.



© Copyright 2001-2012 EMCO Software<%SITE_LABEL%>

Getting Started with EMCO Network Inventory

Knowledgebase Article

11

2. In the context menu that appears, select Load Machine Data > Load From Data File(s).

Load From Data Files

3. In the Open dialog that appears, select the relevant <MACHINE NAME>.mdax5x file and click on the Open
button.

The scan data from the selected machine will be imported into EMCO Network Inventory.

4. If you now open any of the branches in the left panel of the main screen, you will see the imported data.

Main Screen after importing data
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Scanning the Network

EMCO Network Inventory allows you to perform a variety of scan operations on machines in your network.

Use This Scan... To...

 Scan for File  Search the computers on your network for specific files and folders.
 Scan for Disk  Search through the various drives on your local and remote computers for specific types of

files.
 Scan for Registry  Search the registry of local and remote computers for a specific value.
 Scan Registry  Search the registry of local and remote computers for a specific key or value.

Scan for File, Scan for Disk, Scan for Registry and Scan Registry are available only in the EMCO Network
Inventory Enterprise Edition.

Scanning the Network consists of two distinct operations

Defining the Scan, and 

Executing the Scan.

Defining a Scan Operation

1. Expand San operations node, and select one of the Scan nodes.

Selecting the Disk Scan node
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2. Click Add button to add a new item. The Add Scan Task Detail dialog appears.

The Add Scan Task dialog

3. Type a name and description for the job and click OK button.

4. Auto expand the node and select your newly defined task.

5. Press the Add  button to open the Machine Queue dialog.

Clicking on the Add Machine button
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6. Check the required Machines.

Machine Queue

7. Press OK button to proceed.

8. Specify the other settings of the scan.
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Executing the Scan Operation

1. Click  Run Now button to  execute  the  scan.  The  scan is  executed  and  the  scan  results  are  added  to  Scan
Results.

2. Select  the  result  you  want  to  view  details  for  and  click  View.  The  details  for  the  selected  scan  result  are
displayed.

The Results of the Scan

Viewing Reports

Once you have collected data from the various machines on your network, you can view or print reports based on
this data for all or selected machines.

To view or print reports:

1. In the left panel of the EMCO Network Inventory screen, expand the Networking node.

2. Expand the desired Network node.

3. Expand the Domain/Workgroup for which you want to view or print reports.
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4. Select one or more machines from the list of machines in the left panel.

To select multiple machines -

First, click on one machine. 

Hold  down the  Ctrl key and  click  once  on each of the  other  machines  that  you want  to  use  for  the
report.

Release the Ctrl key.

5. Right-click on any of the selected machines.

6. Select Report Selected > To Screen from the context menu.

Instead of the screen, you can also  send  the  report  to  a  PDF,  HTML,  RTF,  JPEG,  or  plain text  file,  by
selecting To Individual File in the context menu.

7. In the Field Output Selection dialog select the fields that you want displayed in your report and click OK.

The Field Output Selection dialog
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Viewing the Report

Exporting Data

You can export part or all of the data you have collected to an Excel file or Access database.

To export data:

1. Expand the Networking node on the left of the EMCO Network Inventory screen.

2. Expand the desired Network node.

3. Expand the Domain/Workgroup you want to view or print reports for.
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4. Select one or more machines from the list of machines in the left pane.

To select multiple machines -

First, click on one machine. 

Hold  down the  Ctrl key and  click  once  on each of the  other  machines  that  you want  to  use  for  the
report.

Release the Ctrl key.

5. Click on File > Export All.

6. In the Field Output Selection dialog select the fields that you want to export and click OK.

The Field Output Selection dialog

7. Type a name for the file you are exporting and select a file type from the Save as type drop-down list.

8. Press Save button to export the data.

Activating EMCO Network Inventory

To avoid piracy of its products EMCO Software follows a license management system. Each product has a license
file which shows that a particular product is registered to a certain company. When you download a trial version of
a product, it generally comes with a free trial license allowing you to use that product during the trial period. When
the evaluation period of that product ends it will not work any more until you purchase a license for it.

The  free  trial version  of  EMCO  Network  Inventory  will  only  run  30  times.  If  you  want  to  continue  using  the
program you should  purchase  a  license  for  it.  When  you  purchase  a  license  for  EMCO  Network  Inventory  a
License Code is sent to you via e-mail.
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To active the EMCO Network Inventory program:

1. Start EMCO Network Inventory.

2. In the Trial dialog that appears whenever  you start  the  trial version of EMCO  Network  Inventory,  press  the
Enter License Code… button.

The Trial dialog

3. In the Enter License Code dialog that appears, enter the License Code that you have  received  via  email,  and
click OK.

You can also open the Enter License Code dialog box by clicking on Help > Enter License Code…

The Help Menu

Your copy of EMCO Network Inventory is now activated.


	What is EMCO Network Inventory
	Main Features of EMCO Network Inventory

	Installing on the Local Machine
	Installing on Remote Computers

	Getting Started with EMCO Network Inventory
	Starting EMCO Network Inventory
	Closing EMCO Network Inventory
	The Main Screen
	Importing Data from the Stub Analyzers into EMCO Network Inventory
	Scanning the Network
	Defining a Scan Operation
	Executing the Scan Operation

	Viewing Reports
	Exporting Data

	Activating EMCO Network Inventory

